Important Notice: Technical Issues Affecting Payouts with Swedbank in SE

Incident Report for Brite Payments

Resolved

We are pleased to inform you that the Swedbank (Sweden) payout delay issue is fully resolved. All transactions are being processed as normal.
Posted Mar 25, 2025 - 17:01 CET

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 25, 2025 - 13:28 CET

Update

We are continuing to actively work with Swedbank on resolving the payout processing delays in Sweden. We do not yet have a full resolution, but the situation remains as previously communicated: payouts are expected to settle within a few hours, with a maximum delay of one business day in rare cases.
Posted Mar 25, 2025 - 10:20 CET

Investigating

We are currently experiencing a delay with processing payouts with Swedbank in Sweden.

Payouts are delayed to settle within a few hours of initiation, but can in rare cases take up to one business day.

We are working closely with the bank to resolve the issue and will keep you updated.
Posted Mar 21, 2025 - 12:00 CET