Säästöpankki, Oma Säästöpankki and POP Bank FI: Technical Issues Identified

Incident Report for Brite Payments

Resolved

Säästöpankki, Oma Säästöpankki and POP Bank resolved their technical issues affecting consumers in Finland. All transactions are now being processed again as normal.
Posted May 18, 2025 - 13:14 CEST

Identified

Säästöpankki, Oma Säästöpankki and POP Bank are experiencing technical issues affecting Finnish consumers paying with these banks.

At the current time, the bank has not communicated an expected time for resolving the issue. However, we are in communication with the bank to stay updated with the latest information and timelines for resolution. Meanwhile, we are looking for alternative solutions.

The next update will take place when we can confirm that the problem has been resolved.
Posted May 18, 2025 - 09:14 CEST
This incident affected: Production API.