NORDEA in SE, FI - Technical issues at the bank

Incident Report for Brite Payments

Resolved

Nordea Bank in Finland and Sweden has resolved its technical issues and transactions are being processed as normal again.
Posted Apr 01, 2025 - 21:43 CEST

Identified

Nordea Bank in Finland and Sweden is experiencing technical issues affecting Finnish and Swedish consumers.

The bank has issued an official communication where it is stated that some of its open banking services like AIS and PIS are having technical issues. However, at present, the bank has not communicated an expected time for resolving these issues. Meanwhile, we are looking for alternative solutions.
Posted Mar 31, 2025 - 10:52 CEST