Important Notice: Technical Issues Affecting Payments/Payouts with Handelsbanken in SE

Incident Report for Brite Payments

Resolved

The technical issues affecting payments and payouts with Handelsbanken in Sweden have been resolved.

All transactions are now being processed as normal again.
Posted Mar 21, 2025 - 16:57 CET

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 20, 2025 - 17:03 CET

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 20, 2025 - 09:45 CET

Investigating

We are currently experiencing a delay with processing payments and payouts with Handelsbanken in Sweden.

Payouts and payments are delayed to settle within a few hours of initiation, but can in rare cases take up to one business day.

We are working closely with the bank to resolve the issue and will keep you updated.
Posted Mar 19, 2025 - 16:01 CET