Swedbank LV - Technical issues at the bank side

Incident Report for Brite Payments

Resolved

Swedbank resolved the technical issues affecting consumers in Latvia. All transactions are now being processed as normal again.
Posted May 10, 2025 - 08:51 CEST

Identified

Swedbank is experiencing technical issues affecting Latvian consumers paying with Swedbank.

For the time being, the bank has not communicated an ETA regarding when the issue will be resolved. We will continue reaching out to the bank to get an official comment. Meanwhile, we are looking for alternative solutions.

An update will be sent out once we have confirmed that the problem has been resolved.
Posted May 09, 2025 - 09:07 CEST