Important Notice: Technical Issues Affecting Payments with S-Pankki in FI

Incident Report for Brite Payments

Resolved

Starting 13 March 2025, S-Pankki Bank experienced reduced performance, which temporarily impacted conversion rates in Finland.

A mitigating fix was rolled out on March 14, 2025 which immediately impacted conversion positively. Following a short period of continuous improvement, conversion has since been restored back to historic levels. Nonetheless, we’re continuing to closely monitor the bank’s performance and are collaborating with the bank’s technical team to determine the root cause.
Posted Mar 19, 2025 - 07:21 CET

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 14, 2025 - 15:39 CET

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 13, 2025 - 10:00 CET

Investigating

We are experiencing technical issues affecting Finnish consumers making payments through S-Pankki.

Our team is actively working to address the issue and is committed to resolving it as quickly as possible. We do not currently have an estimated resolution time, but we are exploring alternative solutions.
Posted Mar 13, 2025 - 00:00 CET