Nordea in SE - Technical issues at the bank

Incident Report for Brite Payments

Resolved

Nordea resolved the technical issues affecting consumers in Sweden. All transactions are now being processed as normal again.
Posted Mar 26, 2025 - 10:38 CET

Investigating

Nordea bank is experiencing technical issues affecting Swedish consumers paying with Nordea.

For the time being, the bank has not communicated an ETA regarding when the issue will be resolved. We will continue reaching out to the bank to get an official comment. Meanwhile, we are looking for alternative solutions.
Posted Mar 21, 2025 - 16:16 CET